Notifications
Clear all

[Solved] Echo sound on the master

2 Posts
2 Users
1 Likes
11 Views
0
Topic starter

Hi,

I'm using the I500 for the first time with Serato DJ Lite, an old Pioneer Amplifier and MP3 files. 

When I play a track and listen to it on the headphones, everything is fine. But when I open the Master volume the track is faster on the Master output. The same happens on the headphones, when I push the headphone button above the chanel control (view photo pls). 

What could be wrong? If you need more specifications...

Thx

Sven

1 Answer
1

Hello,

If your computer operates in Windows, the in Serato DJ, go in Serato settings > Audio, and make sure you disable the setting "Use Laptop Speakers".

If this setting is enabled in Windows while Windows sets the DJ controller as default Windows sound board
- Serato plays the music on DJControl Inpulse 500 Master output in Windows
- Windows (use laptop speakers setting) plays at the same time
then it makes an echo on the master output.

Hedins Topic starter 20/02/2024 11:55 pm

Thx,
it worked perfectly as you described it.