Popping noises on a...
 
Notifications
Clear all

Popping noises on an impulse t7 with serato

4 Posts
3 Users
0 Likes
15 Views
0
Topic starter

Hello

Im a wedding dj out of USA Midwest in Tennessee. I’m recently the proud owner of a new Impulse t7. I’m regretting haveing an issue with it. 
I’m running an Acer I7 2.8 hz with 16 gig of ram on win 11 with serato 3.1 software. I’m getting these odd popping noises in the background of my playing track. Since I can split the track up it’s easier to catch. Tried a ddj-sb3 with same set up and very crisp. Can I get some help with this?

Veng 31/03/2024 8:08 pm

DJ EDDYGEE, have you found a solution to this problem?

3 Answers
0

Hello,

Can you go in Serato DJ settings > Audio, and make sure the setting "Use latpop speakers" is disabled?

0

Same problem here. 

Steps tried:

- Changing buffer settings - no results, I can hear noises and crackles with any settings of audio buffer.

- Disable "Use latpop speakers" - this setting was always disabled, turning it on or off doesn't make any difference.

- Reinstalling t7 drivers and Serato DJ Pro - doesn't help.

- Change Windows settings for best performance - done, doesn't help

- Disable Turbo Boost - doesn't help

- Turning on Airplane mode - doesn't help

- Change max value of processor 98% - doesn't help

- Disable or delete antivirus - doesn't help

- Tried to use different USB ports and different Oyaide and Chroma USB-cables - doesn't help

The only thing that helped - connecting the T7 to Macbook Air with M1-processor and 8gb of RAM, the problem is gone. But I need it to work with my main laptop on Windows!! (which is much more powerful than M1 Macbook Air - Lenovo Legion i7 12700 16Gb GTX3060, Windows 11).

Other Serato DJ controllers work fine and stable with lowest buffer settings on my laptop.

Please help!

This post was modified 3 weeks ago 4 times by Veng
0

Hello Veng,

I do not assume a Windows 11 computer with 16 GB RAM + i7 is more powerful than a M1 Macbook + 8 GB RAM.
Have you set the USB buffer size at 2 or 4ms?
- Find Hercules control panel icon in Windows notification area.

- Right click on the icon, select "Advanced Audio Settings"
- In Advanced audio settings, set a USB buffer size at 2 or 4ms, and an ASIO buffer size at 4ms.