Stream 200 XLR Issu...
Clear all

Stream 200 XLR Issues

14 Posts
4 Users
1 Reactions
Topic starter

I just got the 200XLR, works fine but when I run OBS Studio, over time the program shutsdown on my pc and the Stream 200 goes black. All sound and routing work fine but I have ZERO control. Once I close OBS and stop my live feed the program fires right up. I have tried everything. WebSocket has been disabled and didn't work. I don't know what to do cause support doesn't respond at all. PLEASE HELP

Topic Tags
6 Answers

I have the same problem since yesterdays update. I could make it work for a while with the old controller app version and the new drivers but if you have to restart you have to deinstall everything again and start from the scratch. The Pre amp wont work as well if you do this because you probably cant change mic settings since its a different page from the old to the new version.

Something went completely wrong wish they would do a rollback

CHubb Topic starter 18/04/2024 7:17 pm

I rolled back to v1.3.0 and it ran for an hour no problems at all. Then new one being 1.3.2 is the one that broke everything for me.

swissburgh 19/04/2024 2:10 am

That was the first thing i tried but my pre amp didn't work i don't know if that is because of the new firmware on the interface itself but i cant roll that back sadly

CHubb Topic starter 19/04/2024 7:46 pm

So quick update. On 1.3.0 I went to a podmic and then switched back to my condenser with the lifter and 48v. Wouldn't work at all. Podmic did cause it was dynamic but condenser wouldn't. I updated the software, had a lot of settings and channels to remap but the mic works now and I was live for 2 hours and no problem. Not sure if it was fixed but seems to be working.


Hello Chubb,

Welcome to the discussion area.

As only you can see your computer, settings and configuration, 
- if you can precise your version of application and firmware, forum readers may have suggestions,
- if you do not precise these data, its is difficult to make suggestions.

1) Check versions
Can you go in Settings -> General and check the software version and firmware version of your Stream 200 XLR?

Do you see the following version numbers
Software 1.3.2[01.44]
Firmware 1.88

If yes, everything seems to be properly installed.

If no, you may
- right click on Windows Start
- Settings
- Apps
- Apps & features
- in the list, locate Hercules Stream and uninstall
- in the list, locate Hercules Stream Control and uninstall

Then restart the computer, and, with a user account which is administrator of your Windows, re-install the drivers and app from the installation package you have downloaded from .

 2) If you still cannot run Stream Control App with the pair
Software 1.3.2[01.44]
Firmware 1.88
then you can try closing the app, and going in the folder C:\Users\Username\Appdata\Roaming to delete the "Hercules" directory.


It still crashes for me like 15 seconds after opening OBS. Stream control app is Version 1.3.3[01.44] and firmware is 1.88. I deleted the Hercules folder before restart and reinstall as well and it didn't help.

(edit: i think its Lumia Stream (version 7.5.4) that makes it crash for me. I just tried opening OBS alone and it didn't crash)

(edit 2: so far it works again on version 1.3.0) 


Hey there, maybe i can give some insights to that. I used the hercules 200 XLR for just one day now and i am pretty dissapointed. The device itself is fine - its the software. Without the software the thing is pretty much useless. I was streaming when the software just exited out of nowhere and the device went black. I can reproduce the issue. It happens everytime when somebody subscribes to me on twitch and triggers a subalert. Also, and this is even worse. If i start "Stream Avatars" via Steam - a little software to generate little pixel avatars in your stream for your viewers - the Hercules Software also crashes immediately and wont even start till you exit out of Stream Avatars. I dont know how the subalert or even Stream Avatars are connected to the Hercules Software, but there seems to be a pretty big issue that needs solving immediately! Subalerts are just a integrated browsersource in OBS and Stream Avatars is a whole other software on itself. I dont know what the Hercules Software is made of or using any web/browserplugins but maybe we could get some insight into this.

The Hercules 200 XLR is pretty much useless for streamers in this state!

Software is on Version 1.3.3 (01.44)
Firmware - 1.88

swissburgh 21/04/2024 8:01 pm

I don't get it either. Especially since everything worked fine with the previous version.

CraftyDeluxe 21/04/2024 8:09 pm

Unfortunately i dont have experience with older versions, i got the Hercules 200 just yesterday and it updated itself. But first experience/first stream was a disaster!



Hercules has found a conflict between some games engines and the Hercules stream app 1.3.2
An Hercules stream app update 1.3.4 is now available hercules support website.

CraftyDeluxe 22/04/2024 10:30 pm

Thanks for the quick reply and update. I installed the new Update and will test it for now. So far Stream Avatars work without a crash, but changing the language in the Hercules Software, also changes the language in Stream Avatars so they are still connected somehow - but no crash at least. The subalerts also dont crash the software - so far so good!

Topic starter

Still following the thread. Has the update helped anyone? I am on the 1.3.2 version and the last stream I ran went for a few hours just fine but I am not sure if that was just luck or a fix. 

CraftyDeluxe 23/04/2024 5:26 pm

Yes it helped me. So far i did not stream with it - the update came right after my stream yesterday but i could reproduce the crashes offline while triggering my own Subalerts/Followalerts or launching Stream Avatars - and that works for me now without crashing the software.

swissburgh 24/04/2024 7:31 pm

it worked for me so far. Except i got a weird bug that after a while when i unmute my mic, it always switched between mute and unmute on the creator feed so i heard myself chopped off. The only fix was to disconnect the box from the pc and reconnect it again.