djc inpulse 500: on...
Clear all

djc inpulse 500: only beatsmatch guide comes on and no sound or other buttons work

5 Posts
2 Users
0 Reactions
Topic starter

im new to the forum and djing. just bought a djc inpulse 500 and i cant get it to fully work. it connects and the turntables work when i connect it to virtual dj or djuced but no sound and also none of the other keys are working. my control panel also looks different from the ones i have seen posted here before. hoping someone can help! thanks!


Hello c5getlive,

Welcome to the forum.

1) In DJuced, please confirm your audio settings in your software are:

  • Audio device: DJControl Inpulse 500
  • Master: Outputs 1&2
  • Headphones: Outputs 3&4

2) Regarding "the other keys" which are not working, please confirm if
- In Djuced, when you activate the rotary browser, you see the cursor moving in the library (on track or on folder side)
- in the control panel, at the about tab, do you see the icon between the speaker and the LED icon turn to green when you move faders or rotary buttons on press on keys.

3) Your control panel screenshot seem perfectly OK, it is not the same panel in Windows and in macOS.
I have pointed your first image to the maintenance bot so that it removes it as one can read your unit reference number and it is safer not to make it public  (each unit has a specific reference number so this number belongs to you).
In general, in my screenshots, I hide this reference as hereafter

Topic starter

Thanks for the reply and help!

1.) I made sure that the settings in DJuced matched as you outlined.

2.) Yes I can see the cursor moving when I open DJuced. The LED light only comes on/flashes green when I turn the jogwheel. Faders, sliders and buttons do nothing and it does not turn green. When I use DJuced the jogwheels work but no audio out of controller which is connected to speakers and headphones as advised.

3.) All that is showing on controller is BEATMATCH GUIDE light turned on


Hello c5getlive,

A few further information:

1) Audio testing
a) make sure the master volume rotary potentiometer is not at the minimum
b) confirm you connect the amplified speakers to the controller master output (dual RCA or dual 1/4" jack.
c) precise  the brand & model of the amplified speakers.
b) change you mac default audio output output to DJControl Inpulse 500 in macOS, and try to play the music of a non DJ app as Apple Music: do you hear anything, do you see the master output vumeter LED mov ?

2) Key stuck check-up
Can you check if there is not a key stuck under the top case (then the key will not seem at the same level as the other keys): look at the Vinyl, Slip, Quant and Load keys as if the controller was in demo in a store, stucking a key under the case is a possible action.

3) Test on another computer
I do not think it is computer related, but to make sure it is not specific to your computer, please test on another computer (PC/Mac).

If you have no sound, no key stuck, and same result on another computer, then your controller is either blocked in boot mode or defective. I suggest you contact Hercules support on  so that they check with you if it is not in boot mode and tell you if it is defective.

Topic starter

Thanks again!

  1. Audio
A) Volume rotary potentiometer is not at minimum and in middle
B.) confirmed connection to amplified speakers to controller master output
Master Output to speakers
C.) Speakers Brand/Model: JBL 104BT
D.) Mac default changed to DJC Inpulse 500. Opened Apple Music & Tidal and still cant hear audio connected. when I plug speakers to laptop they work and I can hear audio in DJ software and non-DJ software

2.) Keys dont seem stuck but just to make sure i took off face plate and have been trying to pull up with a guitar pic but still nothing.

3.) I will try on a different computer but i aslo dont feel like thats the issue

4.) After reading some other subjects I think it may be blocked or in boot mode. I keep trying to unstuck keys but dont want to break so I will reach out to support. Not sure why the audio isnt working though. Is that a cause of boot mode or could it just be defective?


Hi c5getlive,

Thanks for the detailed answer.

Please confirm
A)  you have tried disconnecting/reconnecting the USB port as a computer leaving the sleep mode does not properly reset a USB bus powered device. 
B) your USB-C to USB-A adapter has been tested on USB audio devices (Apple removing USB type A connectors and replacing with USB-C is good only if you have good USB-c to USB-A adapters. With poor USB-c adapters, you meet issues with USB audio devices. 

1) Speakers/dj app audio settings/connections/volume seem OK.
2) If keys don't seem stuck, they are not stuck (considering the depth of the keys, once you check it, you see if a key is stuck under the casing ).
3) Another test of DJC Inpulse 500 built-in audio is to click on the speaker icon in the About panel of the DJControl panel: it plays a signal in the front speakers and in the headphones.